请在Chrome、Firefox、IE8+等现代浏览器浏览本站。 本博客所有文章为原创,图片不加水印,随意转载,但请注明来源,谢谢!

Centos下使用yum升级git到非1.7.1的更新版本~

服务器 kxjhwbb 2618℃ 0评论

开发需要用到git,基本上centos默认的git只到1.7.1,如果你用ssh连接,那是没有问题的,但用https就不行了,必须升级。

网上很多方法,但需要自己编译,对于我这种重度yum依赖者,既然有方法用yum,自然是不会放过的。

大致流程

安装rpmforge安装包库

rpm -i 'http://pkgs.repoforge.org/rpmforge-release/rpmforge-release-0.5.3-1.el6.rf.x86_64.rpm'

rpm --import http://apt.sw.be/RPM-GPG-KEY.dag.txt

安装或升级YUM

rpmforge装好后默认启用的库是没有yum 1.7.12的,

但extra里有

更新你的git:yum update --enablerepo=rpmforge-extras git

安装你的git:yum install --enablerepo=rpmforge-extras git

不需要去改rpmforge的repo文件,用参数临时打开就可以了

喜欢 (131)or分享 (0)
发表我的评论
取消评论

表情

Hi,您需要填写昵称和邮箱!

  • 昵称 (必填)
  • 邮箱 (必填)
  • 网址